<!doctype html> <html lang="en-US"> <head> <meta charset="utf-8"> <meta name="viewport" content="width=device-width,initial-scale=1"> <title>A Complete Guide on How To Use Bash Arrays</title> <meta name="generator" content="VuePress 1.5.1"> <link rel="apple-touch-icon" sizes="57x57" href="/assets/favicons/apple-touch-icon-57x57.png"> <link rel="apple-touch-icon" sizes="60x60" href="/assets/favicons/apple-touch-icon-60x60.png"> <link rel="apple-touch-icon" sizes="72x72" href="/assets/favicons/apple-touch-icon-72x72.png"> <link rel="apple-touch-icon" sizes="76x76" href="/assets/favicons/apple-touch-icon-76x76.png"> <link rel="apple-touch-icon" sizes="114x114" href="/assets/favicons/apple-touch-icon-114x114.png"> <link rel="apple-touch-icon" sizes="120x120" href="/assets/favicons/apple-touch-icon-120x120.png"> <link rel="apple-touch-icon" sizes="144x144" href="/assets/favicons/apple-touch-icon-144x144.png"> <link rel="apple-touch-icon" sizes="152x152" href="/assets/favicons/apple-touch-icon-152x152.png"> <link rel="apple-touch-icon" sizes="167x167" href="/assets/favicons/apple-touch-icon-167x167.png"> <link rel="apple-touch-icon" sizes="180x180" href="/assets/favicons/apple-touch-icon-180x180.png"> <link rel="apple-touch-icon" sizes="1024x1024" href="/assets/favicons/apple-touch-icon-1024x1024.png"> <link rel="apple-touch-startup-image" media="(device-width: 320px) and (device-height: 480px) and (-webkit-device-pixel-ratio: 1)" href="/assets/favicons/apple-touch-startup-image-320x460.png"> <link rel="apple-touch-startup-image" media="(device-width: 320px) and (device-height: 480px) and (-webkit-device-pixel-ratio: 2)" href="/assets/favicons/apple-touch-startup-image-640x920.png"> <link rel="apple-touch-startup-image" media="(device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2)" href="/assets/favicons/apple-touch-startup-image-640x1096.png"> <link rel="apple-touch-startup-image" media="(device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2)" href="/assets/favicons/apple-touch-startup-image-750x1294.png"> <link rel="apple-touch-startup-image" media="(device-width: 414px) and (device-height: 736px) and (orientation: landscape) and (-webkit-device-pixel-ratio: 3)" href="/assets/favicons/apple-touch-startup-image-1182x2208.png"> <link rel="apple-touch-startup-image" media="(device-width: 414px) and (device-height: 736px) and (orientation: portrait) and (-webkit-device-pixel-ratio: 3)" href="/assets/favicons/apple-touch-startup-image-1242x2148.png"> <link rel="apple-touch-startup-image" media="(device-width: 768px) and (device-height: 1024px) and (orientation: landscape) and (-webkit-device-pixel-ratio: 1)" href="/assets/favicons/apple-touch-startup-image-748x1024.png"> <link rel="apple-touch-startup-image" media="(device-width: 768px) and (device-height: 1024px) and (orientation: landscape) and (-webkit-device-pixel-ratio: 2)" href="/assets/favicons/apple-touch-startup-image-1496x2048.png"> <link rel="apple-touch-startup-image" media="(device-width: 768px) and (device-height: 1024px) and (orientation: portrait) and (-webkit-device-pixel-ratio: 1)" href="/assets/favicons/apple-touch-startup-image-768x1004.png"> <link rel="apple-touch-startup-image" media="(device-width: 768px) and (device-height: 1024px) and (orientation: portrait) and (-webkit-device-pixel-ratio: 2)" href="/assets/favicons/apple-touch-startup-image-1536x2008.png"> <link rel="icon" type="image/png" sizes="16x16" href="/assets/favicons/favicon-16x16.png"> <link rel="icon" type="image/png" sizes="32x32" href="/assets/favicons/favicon-32x32.png"> <link rel="icon" type="image/png" sizes="228x228" href="/assets/favicons/coast-228x228.png"> <link rel="manifest" href="/assets/favicons/manifest.json"> <link rel="shortcut icon" href="/assets/favicons/favicon.ico"> <link rel="yandex-tableau-widget" href="/assets/favicons/yandex-browser-manifest.json"> <link rel="alternate" type="application/rss+xml" href="/rss.xml"> <link rel="alternate" type="application/atom+xml" href="/atom.xml"> <link rel="alternate" type="application/json" href="/feed.json"><link rel="canonical" href="https://www.shell-tips.com/bash/a-complete-guide-on-how-to-use-bash-arrays/"> <meta name="description" content="Learn how to use bash array variables and associative bash arrays. This guide covers how to declare a bash array, iterate over a bash array, and access keys and values."> <meta name="twitter:card" content="summary"> <meta name="twitter:url" content="https://www.shell-tips.com/bash/a-complete-guide-on-how-to-use-bash-arrays/"> <meta name="twitter:title" content="A Complete Guide on How To Use Bash Arrays"> <meta name="twitter:description" content="Learn how to use bash array variables and associative bash arrays. This guide covers how to declare a bash array, iterate over a bash array, and access keys and values."> <meta name="twitter:creator" content="ShellTipsNow"> <meta name="twitter:image" content="https://www.shell-tips.com/assets/og/a-complete-guide-on-how-to-use-bash-arrays.png"> <meta property="og:url" content="https://www.shell-tips.com/bash/a-complete-guide-on-how-to-use-bash-arrays/"> <meta property="og:type" content="website"> <meta property="og:site_name" content="Shell Tips!"> <meta property="og:title" content="A Complete Guide on How To Use Bash Arrays"> <meta property="og:locale" content="en_US"> <meta property="og:image" content="https://www.shell-tips.com/assets/og/a-complete-guide-on-how-to-use-bash-arrays.png"> <meta property="og:image:width" content="1024"> <meta property="og:image:height" content="512"> <meta property="og:image" content="https://www.shell-tips.com/assets/pin/a-complete-guide-on-how-to-use-bash-arrays.png"> <meta property="og:image:width" content="1000"> <meta property="og:image:height" content="1500"> <meta name="author" content="Nicolas Brousse"> <meta itemprop="name" content="A Complete Guide on How To Use Bash Arrays"> <meta itemprop="description" content="Learn how to use bash array variables and associative bash arrays. This guide covers how to declare a bash array, iterate over a bash array, and access keys and values."> <meta itemprop="url" content="https://www.shell-tips.com/bash/a-complete-guide-on-how-to-use-bash-arrays/"> <meta itemprop="image" content="https://www.shell-tips.com/assets/og/a-complete-guide-on-how-to-use-bash-arrays.png"> <meta name="apple-mobile-web-app-capable" content="yes"> <meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"> <meta name="apple-mobile-web-app-title"> <meta name="application-name"> <meta name="mobile-web-app-capable" content="yes"> <meta name="msapplication-TileColor" content="#fff"> <meta name="msapplication-TileImage" content="/assets/favicons/mstile-144x144.png"> <meta name="msapplication-config" content="/assets/favicons/browserconfig.xml"> <meta name="theme-color" content="#fff"> <link rel="preload" href="/assets/css/0.styles.643e0809.css" as="style"><link rel="preload" href="/assets/js/app.f2436115.js" as="script"><link rel="preload" href="/assets/js/44.8c8e5ed0.js" as="script"><link rel="preload" href="/assets/js/18.a6aa1d28.js" as="script"><link rel="preload" href="/assets/js/52.45429b0b.js" as="script"><link rel="preload" href="/assets/js/46.9b4ac1d9.js" as="script"><link rel="preload" href="/assets/js/2.e285a825.js" as="script"><link rel="preload" href="/assets/js/1.a1680d06.js" as="script"><link rel="preload" href="/assets/js/62.2b7abdca.js" as="script"><link rel="preload" href="/assets/js/23.617fc7ac.js" as="script"><link rel="preload" href="/assets/js/41.fe8e8243.js" as="script"><link rel="preload" href="/assets/js/37.1f6a2ba5.js" as="script"><link rel="preload" href="/assets/js/47.ae9309c7.js" as="script"> <link rel="stylesheet" href="/assets/css/0.styles.643e0809.css"> </head> <body> <div id="app" data-server-rendered="true"><div data-app="true" id="st-app" class="v-application v-application--is-ltr theme--light"><div class="v-application--wrap"><div data-v-4c95a312><header id="home-app-bar" class="v-sheet theme--dark elevation-1 v-toolbar v-app-bar v-app-bar--fixed primary" style="height:50px;margin-top:0;transform:translateY(0);left:0;right:0" data-v-4c95a312><div class="v-toolbar__content" style="height:50px"><a href="/" class="white--text font-weight-bold router-link-active" data-v-4c95a312><span aria-hidden="true" class="v-icon notranslate mx-1 mb-1 v-icon--svg theme--dark" data-v-4c95a312><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M20,19V7H4V19H20M20,3A2,2 0 0,1 22,5V19A2,2 0 0,1 20,21H4A2,2 0 0,1 2,19V5C2,3.89 2.9,3 4,3H20M13,17V15H18V17H13M9.58,13L5.57,9H8.4L11.7,12.3C12.09,12.69 12.09,13.33 11.7,13.72L8.42,17H5.59L9.58,13Z"></path></svg></span> Shell Tips!</a> <div class="spacer" data-v-4c95a312></div> <div class="search-box mr-6" data-v-4c95a312><input aria-label="Search" autocomplete="off" spellcheck="false"> </div> <div data-v-4c95a312><div min-width="56" class="v-tabs hidden-sm-and-down theme--dark" data-v-4c95a312><div role="tablist" class="v-item-group theme--dark v-slide-group v-tabs-bar v-tabs-bar--is-mobile white--text primary"><div class="v-slide-group__prev v-slide-group__prev--disabled"></div><div class="v-slide-group__wrapper"><div class="v-slide-group__content v-tabs-bar__content"><div class="v-tabs-slider-wrapper" style="transition:none"><div class="v-tabs-slider"></div></div><a href="/bash/" aria-current="page" tabindex="0" aria-selected="false" role="tab" min-width="56" text="" class="font-weight-bold white--text v-tab--active v-tab" data-v-4c95a312> Bash </a><a href="/linux/" tabindex="0" aria-selected="false" role="tab" min-width="56" text="" class="font-weight-bold v-tab" data-v-4c95a312> Linux </a><a href="/mac/" tabindex="0" aria-selected="false" role="tab" min-width="56" text="" class="font-weight-bold v-tab" data-v-4c95a312> Mac </a><a href="/windows/" tabindex="0" aria-selected="false" role="tab" min-width="56" text="" class="font-weight-bold v-tab" data-v-4c95a312> Windows </a><a href="/cheat-sheets/" tabindex="0" aria-selected="false" role="tab" min-width="56" text="" class="font-weight-bold v-tab" data-v-4c95a312> Cheat Sheets </a></div></div><div class="v-slide-group__next v-slide-group__next--disabled"></div></div></div></div> <button type="button" class="v-app-bar__nav-icon hidden-md-and-up v-btn v-btn--flat v-btn--icon v-btn--round theme--dark v-size--default" data-v-4c95a312><span class="v-btn__content"><span aria-hidden="true" class="v-icon notranslate v-icon--svg theme--dark" data-v-4c95a312><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M3,6H21V8H3V6M3,11H21V13H3V11M3,16H21V18H3V16Z"></path></svg></span></span></button></div></header> <aside class="v-navigation-drawer v-navigation-drawer--bottom v-navigation-drawer--close v-navigation-drawer--fixed v-navigation-drawer--is-mobile v-navigation-drawer--temporary theme--light transparent" style="height:auto;top:auto;transform:translateY(100%);width:100%" data-v-4c95a312><div class="v-navigation-drawer__content"><div role="list" class="v-list v-sheet v-sheet--shaped theme--light white"><a href="/bash/" tabindex="0" role="listitem" class="v-list-item v-list-item--link theme--light primary--text"><div class="v-list-item__content"><div class="v-list-item__title"><span aria-hidden="true" class="v-icon notranslate mx-1 mb-1 v-icon--svg theme--light"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M5 9H7.31L7.63 6H9.63L9.31 9H11.31L11.63 6H13.63L13.31 9H15V11H13.1L12.9 13H15V15H12.69L12.37 18H10.37L10.69 15H8.69L8.37 18H6.37L6.69 15H5V13H6.9L7.1 11H5V9M9.1 11L8.9 13H10.9L11.1 11M19 6H17V14H19M19 16H17V18H19Z"></path></svg></span> Bash </div></div></a><a href="/linux/" tabindex="0" role="listitem" class="v-list-item v-list-item--link theme--light primary--text"><div class="v-list-item__content"><div class="v-list-item__title"><span aria-hidden="true" class="v-icon notranslate mx-1 mb-1 v-icon--svg theme--light"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M14.62,8.35C14.2,8.63 12.87,9.39 12.67,9.54C12.28,9.85 11.92,9.83 11.53,9.53C11.33,9.37 10,8.61 9.58,8.34C9.1,8.03 9.13,7.64 9.66,7.42C11.3,6.73 12.94,6.78 14.57,7.45C15.06,7.66 15.08,8.05 14.62,8.35M21.84,15.63C20.91,13.54 19.64,11.64 18,9.97C17.47,9.42 17.14,8.8 16.94,8.09C16.84,7.76 16.77,7.42 16.7,7.08C16.5,6.2 16.41,5.3 16,4.47C15.27,2.89 14,2.07 12.16,2C10.35,2.05 9,2.81 8.21,4.4C8,4.83 7.85,5.28 7.75,5.74C7.58,6.5 7.43,7.29 7.25,8.06C7.1,8.71 6.8,9.27 6.29,9.77C4.68,11.34 3.39,13.14 2.41,15.12C2.27,15.41 2.13,15.7 2.04,16C1.85,16.66 2.33,17.12 3.03,16.96C3.47,16.87 3.91,16.78 4.33,16.65C4.74,16.5 4.9,16.6 5,17C5.65,19.15 7.07,20.66 9.24,21.5C13.36,23.06 18.17,20.84 19.21,16.92C19.28,16.65 19.38,16.55 19.68,16.65C20.14,16.79 20.61,16.89 21.08,17C21.57,17.09 21.93,16.84 22,16.36C22.03,16.1 21.94,15.87 21.84,15.63"></path></svg></span> Linux </div></div></a><a href="/mac/" tabindex="0" role="listitem" class="v-list-item v-list-item--link theme--light primary--text"><div class="v-list-item__content"><div class="v-list-item__title"><span aria-hidden="true" class="v-icon notranslate mx-1 mb-1 v-icon--svg theme--light"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M18.71,19.5C17.88,20.74 17,21.95 15.66,21.97C14.32,22 13.89,21.18 12.37,21.18C10.84,21.18 10.37,21.95 9.1,22C7.79,22.05 6.8,20.68 5.96,19.47C4.25,17 2.94,12.45 4.7,9.39C5.57,7.87 7.13,6.91 8.82,6.88C10.1,6.86 11.32,7.75 12.11,7.75C12.89,7.75 14.37,6.68 15.92,6.84C16.57,6.87 18.39,7.1 19.56,8.82C19.47,8.88 17.39,10.1 17.41,12.63C17.44,15.65 20.06,16.66 20.09,16.67C20.06,16.74 19.67,18.11 18.71,19.5M13,3.5C13.73,2.67 14.94,2.04 15.94,2C16.07,3.17 15.6,4.35 14.9,5.19C14.21,6.04 13.07,6.7 11.95,6.61C11.8,5.46 12.36,4.26 13,3.5Z"></path></svg></span> Mac </div></div></a><a href="/windows/" tabindex="0" role="listitem" class="v-list-item v-list-item--link theme--light primary--text"><div class="v-list-item__content"><div class="v-list-item__title"><span aria-hidden="true" class="v-icon notranslate mx-1 mb-1 v-icon--svg theme--light"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M3,12V6.75L9,5.43V11.91L3,12M20,3V11.75L10,11.9V5.21L20,3M3,13L9,13.09V19.9L3,18.75V13M20,13.25V22L10,20.09V13.1L20,13.25Z"></path></svg></span> Windows </div></div></a><a href="/cheat-sheets/" tabindex="0" role="listitem" class="v-list-item v-list-item--link theme--light primary--text"><div class="v-list-item__content"><div class="v-list-item__title"><span aria-hidden="true" class="v-icon notranslate mx-1 mb-1 v-icon--svg theme--light"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M19.79,15.41C20.74,13.24 20.74,10.75 19.79,8.59L17.05,9.83C17.65,11.21 17.65,12.78 17.06,14.17L19.79,15.41M15.42,4.21C13.25,3.26 10.76,3.26 8.59,4.21L9.83,6.94C11.22,6.35 12.79,6.35 14.18,6.95L15.42,4.21M4.21,8.58C3.26,10.76 3.26,13.24 4.21,15.42L6.95,14.17C6.35,12.79 6.35,11.21 6.95,9.82L4.21,8.58M8.59,19.79C10.76,20.74 13.25,20.74 15.42,19.78L14.18,17.05C12.8,17.65 11.22,17.65 9.84,17.06L8.59,19.79M12,2A10,10 0 0,1 22,12A10,10 0 0,1 12,22A10,10 0 0,1 2,12A10,10 0 0,1 12,2M12,8A4,4 0 0,0 8,12A4,4 0 0,0 12,16A4,4 0 0,0 16,12A4,4 0 0,0 12,8Z"></path></svg></span> Cheat Sheets </div></div></a></div></div><div class="v-navigation-drawer__border"></div></aside></div> <button type="button" class="mb-5 v-btn v-btn--bottom v-btn--contained v-btn--fab v-btn--fixed v-btn--right v-btn--round theme--dark v-size--default secondary" style="display:none"><span class="v-btn__content"><span aria-hidden="true" class="v-icon notranslate v-icon--svg theme--dark"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M7.41,15.41L12,10.83L16.59,15.41L18,14L12,8L6,14L7.41,15.41Z"></path></svg></span></span></button> <main class="v-main" style="padding-top:50px;padding-right:0;padding-bottom:0;padding-left:0"><div class="v-main__wrap"><div class="row no-gutters"><div class="col col-12"><div itemscope itemtype="http://schema.org/BlogPosting"><section id="hero-alt"><div color="#45516b" flat="" tile="" height="225" gradient="to right, rgba(4, 26, 6, .4), rgba(4, 26, 6, .7)" src="/assets/tn/450x300/a-complete-guide-on-how-to-use-bash-arrays.jpg" max-width="100%" class="v-image v-responsive theme--dark" style="height:225px;max-width:100%"><div class="v-image__image v-image__image--preload v-image__image--cover" style="background-image:linear-gradient(to right,rgba(4,26,6,.4),rgba(4,26,6,.7));background-position:center center"></div><div class="v-responsive__content"><div class="row ma-0 fill-height text-center align-center justify-center"><div class="col col-12"><h1 itemprop="name headline" class="text-capitalize mt-0 display-1 font-weight-500 mb-2 text-center white--text"><span>A Complete Guide on <span class="amber--text text--darken-1">How</span> <span class="amber--text text--darken-1">To</span> Use <span class="amber--text text--darken-1">Bash</span> <span class="amber--text text--darken-1">Arrays</span></span></h1> <div class="v-responsive base-divider info mx-auto mb-6 base-divider--dense" style="max-width:28px"><div class="v-responsive__content"><hr role="separator" aria-orientation="horizontal" class="v-divider theme--dark"></div></div> <ul class="v-breadcrumbs justify-center pa-0 text-capitalize theme--dark"><li><a href="/" class="v-breadcrumbs__item">HOME</a></li><li class="v-breadcrumbs__divider">></li><li><a href="/bash/" class="v-breadcrumbs__item">BASH</a></li><li class="v-breadcrumbs__divider">></li><li><div class="v-breadcrumbs__item">A Complete Guide on How To Use Bash Arrays</div></li></ul></div></div></div></div></section> <section id="blog-post" style="padding:0 0"><div class="container"><div class="row mt-n6 mx-auto d-flex justify-center" style="max-width:720px"><div class="col col-12"><div class="d-flex justify-space-between flex-wrap text-left grey--text mt-0 primary text--lighten-4 pa-1 caption"><div class="d-flex"><div itemprop="datePublished" style="display:none">January 26, 2020</div> <span aria-hidden="true" class="v-icon notranslate mx-1 mt-1 grey--text text--lighten-4 v-icon--svg theme--light" style="font-size:16px;height:16px;width:16px"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="16px" width="16px" role="img" aria-hidden="true"><path d="M9,10V12H7V10H9M13,10V12H11V10H13M17,10V12H15V10H17M19,3A2,2 0 0,1 21,5V19A2,2 0 0,1 19,21H5C3.89,21 3,20.1 3,19V5A2,2 0 0,1 5,3H6V1H8V3H16V1H18V3H19M19,19V8H5V19H19M9,14V16H7V14H9M13,14V16H11V14H13M17,14V16H15V14H17Z"></path></svg></span>Last Updated: <time itemprop="dateModified">July 4, 2020</time></div> <div class="d-flex flex-wrap"><span class="hidden-sm-and-down">subscribe to my <a href="#newsletter" class="white--text">newsletter</a></span></div></div> <div class="spacer pb-6"></div> <div itemprop="articleBody description" class="content__default"><p>The <em><strong>Bash array variables</strong></em>, also known as <em>one-dimensional indexed arrays or lists</em>, came with the version 2 of Bash. With version 4 came the support for <em><strong>associative arrays</strong></em>, also known as <em>dictionaries or hash tables</em>. The support for <strong>Bash Arrays</strong> simplifies heavily how you can write your shell scripts to support more complex logic.</p> <p>This guide covers the standard <em>bash array operations</em> and how to <em>declare</em> (<em>set</em>), <em>append</em>, <em>iterate over</em> (<em>loop</em>), <em>check</em> (<em>test</em>), <em>access</em> (<em>get</em>), and <em>delete</em> (<em>unset</em>) a value in an <em>indexed bash array</em> and an <em>associative bash array</em>.</p> <blockquote><p>👉 Many fixes and improvements have been made with Bash version 5, read more details with the post <a href="/bash/what-is-new-in-gnu-bash-5/">What's New in GNU Bash 5?</a></p></blockquote> <p></p><div class="table-of-contents"><ul><li><a href="#difference-between-bash-indexed-arrays-and-associative-arrays">Difference between Bash Indexed Arrays and Associative Arrays</a></li><li><a href="#how-to-declare-a-bash-array">How to declare a Bash Array?</a><ul><li><a href="#bash-indexed-array-ordered-lists">Bash Indexed Array (ordered lists)</a></li><li><a href="#bash-associative-array-dictionaries-hash-table-or-key-value-pair">Bash Associative Array (dictionaries, hash table, or key/value pair)</a></li></ul></li><li><a href="#array-operations">Array Operations</a><ul><li><a href="#how-to-iterate-over-a-bash-array-loop">How to iterate over a Bash Array? (loop)</a></li><li><a href="#how-to-get-the-key-value-pair-of-a-bash-array-obtain-keys-or-indices">How to get the Key/Value pair of a Bash Array? (Obtain Keys or Indices)</a></li><li><a href="#how-to-get-a-bash-array-size-array-length">How to get a Bash Array size? (Array length)</a></li><li><a href="#how-to-remove-a-key-from-a-bash-array-or-delete-the-full-array-delete">How to remove a key from a Bash Array or delete the full array? (delete)</a></li></ul></li><li><a href="#detailed-examples-faq">Detailed Examples & FAQ</a><ul><li><a href="#how-to-shuffle-the-elements-of-an-array-in-a-shell-script">How to shuffle the elements of an Array in a shell script?</a></li><li><a href="#how-to-check-if-a-bash-array-contains-a-value">How to check if a Bash Array contains a value?</a></li></ul></li></ul></div><p></p> <h2 id="difference-between-bash-indexed-arrays-and-associative-arrays">Difference between Bash Indexed Arrays and Associative Arrays</h2> <p>First and foremost, you need to differentiate the two types of arrays that can be used in bash. An <code>indexed</code> array is an array in which the keys (indexes) are ordered integers. You can think about it as an ordered list of items. Then, an <code>associative</code> array, a.k.a <a href="https://en.wikipedia.org/wiki/Hash_table" target="_blank" rel="noopener noreferrer"><code>hash table</code></a>, is an array in which the keys are represented by arbitrary strings.</p> <h2 id="how-to-declare-a-bash-array">How to declare a Bash Array?</h2> <p>Arrays in Bash are one-dimensional array variables. The <code>declare</code> shell builtin is used to declare array variables and give them attributes using the <code>-a</code> and <code>-A</code> options. Note that there is no upper limit (maximum) on the size (length) of a Bash array and the values in an Indexed Array and an Associative Array can be any strings or numbers, with the <em>null string</em> being a valid value.</p> <blockquote><p>👉 Remember that the <em>null string</em> is a zero-length string, which is an empty string. This is not to be confused with the <a href="/bash/what-is-the-bash-null-command/">bash null command</a> which has a completely different meaning and purpose.</p></blockquote> <h3 id="bash-indexed-array-ordered-lists">Bash Indexed Array (ordered lists)</h3> <p>You can create an Indexed Array on the fly in Bash using compound assignment or by using the builtin command <code>declare</code>. The <code>+=</code> operator allows you to append a value to an indexed Bash array.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myIndexedArray</span><span class="token operator">=</span><span class="token punctuation">(</span>one two three<span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myIndexedArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
one two three

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ myIndexedArray<span class="token punctuation">[</span><span class="token number">5</span><span class="token punctuation">]</span><span class="token operator">=</span><span class="token string">'five'</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myIndexedArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
one two three five

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ myIndexedArray<span class="token punctuation">[</span><span class="token number">4</span><span class="token punctuation">]</span><span class="token operator">=</span><span class="token string">'four'</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myIndexedArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
one two three four five

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myIndexedArray</span><span class="token operator">+=</span><span class="token punctuation">(</span><span class="token string">'six'</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myIndexedArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
one two three four five six
</code></pre></div><p>With the <code>declare</code> built-in command and the lowercase "<code>-a</code>" option, you would simply do the following:</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">declare</span> -a mySecondIndexedArray
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ mySecondIndexedArray<span class="token punctuation">[</span><span class="token number">0</span><span class="token punctuation">]</span><span class="token operator">=</span><span class="token string">'zero'</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${mySecondIndexedArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
zero
</code></pre></div><h3 id="bash-associative-array-dictionaries-hash-table-or-key-value-pair">Bash Associative Array (dictionaries, hash table, or key/value pair)</h3> <p>You <em>cannot</em> create an associative array on the fly in Bash. You can only use the <code>declare</code> built-in command with the uppercase "<code>-A</code>" option. The <code>+=</code> operator allows you to append one or multiple key/value to an associative Bash array.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">declare</span> -A myAssociativeArray
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ myAssociativeArray<span class="token punctuation">[</span>a<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">123</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ myAssociativeArray<span class="token punctuation">[</span>b<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">456</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myAssociativeArray</span><span class="token operator">+=</span><span class="token punctuation">(</span><span class="token punctuation">[</span>c<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">789</span> <span class="token punctuation">[</span>d<span class="token punctuation">]</span><span class="token operator">=</span>012<span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
012 <span class="token number">789</span> <span class="token number">456</span> <span class="token number">123</span>
</code></pre></div><blockquote><p>⚠️ Do not confuse <code>-a</code> (lowercase) with <code>-A</code> (uppercase). It would silently fail. Indeed, declaring an Indexed array will accept subscript but will ignore it and treat the rest of your declaration as an Indexed Array, not an Associative Array.</p></blockquote> <blockquote><p>👉 Read more about the common error <em>"<a href="/bash/bash-error-must-use-subscript-when-assigning-associative-array/">Bash Error: must use subscript when assigning associative array</a>"</em>.</p></blockquote> <h2 id="array-operations">Array Operations</h2> <h3 id="how-to-iterate-over-a-bash-array-loop">How to iterate over a Bash Array? (loop)</h3> <p>As we saw above, we can access all the values of a Bash array using the <code>*</code> (wildcard) notation. Though, to iterate through all the array values you should use the <code>@</code> (at) notation instead.</p> <p>The difference between the two will arise when you try to loop over such an array using quotes. The <code>*</code> notation will return all the elements of the array as a single word result while the <code>@</code> notation will return a value for each element of the Bash array as a separate word. This becomes clear when performing a <a href="/bash/what-is-the-right-way-to-loop-in-bash/#the-for-loop">for loop</a> on such a variable.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myDemoArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token number">1</span> <span class="token number">2</span> <span class="token number">3</span> <span class="token number">4</span> <span class="token number">5</span><span class="token punctuation">)</span>

<span class="token comment"># Using '*'</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myDemoArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
<span class="token number">1</span> <span class="token number">2</span> <span class="token number">3</span> <span class="token number">4</span> <span class="token number">5</span>

<span class="token comment"># Using '@'</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myDemoArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>
<span class="token number">1</span> <span class="token number">2</span> <span class="token number">3</span> <span class="token number">4</span> <span class="token number">5</span>

<span class="token comment"># For Loop Exampe with '*', will echo only once all the values</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myDemoArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token number">1</span> <span class="token number">2</span> <span class="token number">3</span> <span class="token number">4</span> <span class="token number">5</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token keyword">for</span> <span class="token for-or-select variable">value</span> <span class="token keyword">in</span> <span class="token string">"<span class="token variable">${myDemoArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>"</span><span class="token punctuation">;</span> <span class="token keyword">do</span> <span class="token builtin class-name">echo</span> <span class="token string">"<span class="token variable">$value</span>"</span><span class="token punctuation">;</span> <span class="token keyword">done</span>
<span class="token number">1</span> <span class="token number">2</span> <span class="token number">3</span> <span class="token number">4</span> <span class="token number">5</span>

<span class="token comment"># For Loop Example with '@', will echo individually each values</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myDemoArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token number">1</span> <span class="token number">2</span> <span class="token number">3</span> <span class="token number">4</span> <span class="token number">5</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token keyword">for</span> <span class="token for-or-select variable">value</span> <span class="token keyword">in</span> <span class="token string">"<span class="token variable">${myDemoArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span><span class="token punctuation">;</span> <span class="token keyword">do</span> <span class="token builtin class-name">echo</span> <span class="token string">"<span class="token variable">$value</span>"</span><span class="token punctuation">;</span> <span class="token keyword">done</span>
<span class="token number">1</span>
<span class="token number">2</span>
<span class="token number">3</span>
<span class="token number">4</span>
<span class="token number">5</span>
</code></pre></div><h3 id="how-to-get-the-key-value-pair-of-a-bash-array-obtain-keys-or-indices">How to get the Key/Value pair of a Bash Array? (Obtain Keys or Indices)</h3> <p>When looping over a Bash array it's often useful to access the keys of the array separately of the values. This can be done by using the <code>!</code> (bang) notation.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token comment"># Print Indexed Array Keys</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token keyword">for</span> <span class="token for-or-select variable">keys</span> <span class="token keyword">in</span> <span class="token string">"<span class="token variable">${<span class="token operator">!</span>myDemoArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span><span class="token punctuation">;</span> <span class="token keyword">do</span> <span class="token builtin class-name">echo</span> <span class="token string">"<span class="token variable">$keys</span>"</span><span class="token punctuation">;</span> <span class="token keyword">done</span>
<span class="token number">0</span>
<span class="token number">1</span>
<span class="token number">2</span>
<span class="token number">3</span>
<span class="token number">4</span>

<span class="token comment"># Print Associative Array Values</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myAssociativeArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token punctuation">[</span>a<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">123</span> <span class="token punctuation">[</span>b<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">456</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token keyword">for</span> <span class="token for-or-select variable">value</span> <span class="token keyword">in</span> <span class="token string">"<span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span><span class="token punctuation">;</span> <span class="token keyword">do</span> <span class="token builtin class-name">echo</span> <span class="token string">"<span class="token variable">$value</span>"</span><span class="token punctuation">;</span> <span class="token keyword">done</span>
<span class="token number">456</span>
<span class="token number">123</span>

<span class="token comment"># Print Associative Array Keys</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myAssociativeArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token punctuation">[</span>a<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">123</span> <span class="token punctuation">[</span>b<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">456</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token keyword">for</span> <span class="token for-or-select variable">keys</span> <span class="token keyword">in</span> <span class="token string">"<span class="token variable">${<span class="token operator">!</span>myAssociativeArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span><span class="token punctuation">;</span> <span class="token keyword">do</span> <span class="token builtin class-name">echo</span> <span class="token string">"<span class="token variable">$keys</span>"</span><span class="token punctuation">;</span> <span class="token keyword">done</span>
b
a

<span class="token comment"># Iterate over key and value of an Associative Array</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myAssociativeArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token punctuation">[</span>a<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">123</span> <span class="token punctuation">[</span>b<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">456</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token keyword">for</span> <span class="token for-or-select variable">key</span> <span class="token keyword">in</span> <span class="token string">"<span class="token variable">${<span class="token operator">!</span>myAssociativeArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span>
<span class="token operator">></span> <span class="token keyword">do</span>
<span class="token operator">></span>   <span class="token builtin class-name">echo</span> -n <span class="token string">"key  : <span class="token variable">$key</span>, "</span>
<span class="token operator">></span>   <span class="token builtin class-name">echo</span> <span class="token string">"value: <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>$key<span class="token punctuation">]</span>}</span>"</span>
<span class="token operator">></span> <span class="token keyword">done</span>
key  <span class="token builtin class-name">:</span> b, value: <span class="token number">456</span>
key  <span class="token builtin class-name">:</span> a, value: <span class="token number">123</span>
</code></pre></div><h3 id="how-to-get-a-bash-array-size-array-length">How to get a Bash Array size? (Array length)</h3> <p>Another useful aspect of manipulating Bash Arrays is to be able to get the total count of all the elements in an array. You can get the length (i.e. size) of an Array variable with the <code>#</code> (hashtag) notation.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span>a b c d<span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token string">"myArray contain <span class="token variable">${<span class="token operator">#</span>myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> elements"</span>
myArray contain <span class="token number">4</span> elements

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myAssociativeArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token punctuation">[</span>a<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">123</span> <span class="token punctuation">[</span>b<span class="token punctuation">]</span><span class="token operator">=</span><span class="token number">456</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token string">"myAssociativeArray contain <span class="token variable">${<span class="token operator">#</span>myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> elements"</span>
myAssociativeArray contain <span class="token number">2</span> elements
</code></pre></div><h3 id="how-to-remove-a-key-from-a-bash-array-or-delete-the-full-array-delete">How to remove a key from a Bash Array or delete the full array? (delete)</h3> <p>The <code>unset</code> bash builtin command is used to <em>unset</em> (delete or remove) any values and attributes from a shell variable or function. This means that you can simply use it to <em>delete</em> a Bash array in full or only <em>remove</em> part of it by specifying the key. <code>unset</code> take the variable name as an argument, so don't forget to remove the <code>$</code> (dollar) sign in front of the variable name of your array. See the complete example below.</p> <div class="language- extra-class"><pre class="language-text"><code>[me@linux ~]$ declare -A myArray=([one]=un [two]=deux [three]=trois)
[me@linux ~]$ echo ${myArray[*]}
deux trois un
[me@linux ~]$ echo ${myArray[one]}
un
[me@linux ~]$ unset myArray[one]
[me@linux ~]$ echo ${myArray[*]}
deux trois
[me@linux ~]$ unset myArray
[me@linux ~]$ echo ${myArray[*]}

</code></pre></div><h2 id="detailed-examples-faq">Detailed Examples & FAQ</h2> <h3 id="how-to-shuffle-the-elements-of-an-array-in-a-shell-script">How to shuffle the elements of an Array in a shell script?</h3> <p>There are two reasonable options to shuffle the elements of a bash array in a shell script. First, you can either use the external command-line tool <code>shuf</code> that comes with the GNU coreutils, or <code>sort -R</code> in older coreutils versions. Second, you can use a native bash implementation with only shell builtin and a randomization function. Both methods presented below assume the use of an indexed array, it will not work with associative arrays.</p> <p>The <code>shuf</code> command line generates random permutations from a file or the standard input. By using the <code>-e</code> option, <code>shuf</code> would treat each argument as a separate input line. <em><strong>Do not forget to use the double-quote otherwise elements with whitespaces will be split</strong></em>. Once the array is shuffled we can reassign its new value to the same variable.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token string">"1st item"</span> <span class="token string">"2nd item"</span> <span class="token string">"3rd item"</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>  
1st item 2nd item 3rd item

<span class="token comment"># CORRECT: Uses double-quote</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token function">shuf</span> -e <span class="token string">"<span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span>
2nd item
1st item
3rd item

<span class="token comment"># WRONG: Missing double-quote</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token function">shuf</span> -e <span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>
2nd
item
item
1st
3rd
item

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span> <span class="token variable"><span class="token variable">$(</span><span class="token function">shuf</span> -e <span class="token string">"<span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span><span class="token variable">)</span></span> <span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>
2nd item 1st item 3rd item
</code></pre></div><p>The second option to shuffle the elements of a bash array is to implement an unbiased algorithm like the <a href="https://en.wikipedia.org/wiki/Fisher%E2%80%93Yates_shuffle" target="_blank" rel="noopener noreferrer">Fisher-Yates shuffle</a>. The challenge to implement such a solution is that you may need to few bash tricks to work around some limitations. For example, a bash function return value is limited to number values between 0 and 255, nor can you <em>safely</em> use indirection in bash. This example will implement a <code>rand</code> function and a <code>shuffle</code> function. Both function uses local and global variables to pass values around. If you need to shuffle an array larger than 32768 entries or your array is not a dense indexed array, then use the first method above using <code>shuf</code>.</p> <p>We want to ensure that every permutation is equally likely when shuffling the array. The first function <code>rand</code> generates a random number as simply using <code>$((RANDOM % i))</code> with just the <a href="/bash/performing-math-calculation-in-bash/">modulo operator in bash arithmetic</a> would produce a biased number. We compensate this by using a range of values that is a multiple of the $RANDOM modulus. The $RANDOM number in bash range between 0 and 32767. Since we still rely on this number, it will limit our max random number generator to 32768 values. We use a <a href="/bash/what-is-the-right-way-to-loop-in-bash/#the-while-loop">bash while loop</a> with the <a href="/bash/what-is-the-bash-null-command/">bash null command</a> to iterate over a series of $RANDOM numbers until we get one below the max value. We use a <a href="/bash/how-to-script-powerful-bash-if-statement/">bash if statement</a> to ensure that we don't end up in an infinite loop in cases where max value is zero which would happen if we provide a number larger than 32768 to <code>rand</code>.</p> <p>The <code>shuffle</code> function uses a <a href="/bash/what-is-the-right-way-to-loop-in-bash/#the-for-loop">bash for loop</a> to permute they entries in the array based on the unbiased random number we generated with the <code>rand</code> function.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token comment"># generate a random number from 0 to ($1-1)</span>
<span class="token comment"># GLOBALS: _RANDOM.</span>
<span class="token function-name function">rand</span><span class="token punctuation">(</span><span class="token punctuation">)</span> <span class="token punctuation">{</span>
  <span class="token builtin class-name">local</span> <span class="token assign-left variable">max</span><span class="token operator">=</span><span class="token variable"><span class="token variable">$((</span><span class="token number">32768</span> <span class="token operator">/</span> $<span class="token number">1</span> <span class="token operator">*</span> $<span class="token number">1</span><span class="token variable">))</span></span>
  <span class="token keyword">if</span> <span class="token variable"><span class="token punctuation">((</span> $max <span class="token operator">></span> <span class="token number">0</span> <span class="token punctuation">))</span></span><span class="token punctuation">;</span> <span class="token keyword">then</span>
    <span class="token keyword">while</span> <span class="token variable"><span class="token punctuation">((</span> <span class="token punctuation">(</span>_RANDOM<span class="token operator">=</span>$RANDOM<span class="token punctuation">)</span> <span class="token operator">>=</span> max <span class="token punctuation">))</span></span><span class="token punctuation">;</span> <span class="token keyword">do</span> <span class="token builtin class-name">:</span><span class="token punctuation">;</span> <span class="token keyword">done</span>
    <span class="token assign-left variable">_RANDOM</span><span class="token operator">=</span><span class="token variable"><span class="token variable">$((</span> _RANDOM <span class="token operator">%</span> $<span class="token number">1</span> <span class="token variable">))</span></span>
  <span class="token keyword">else</span>
    <span class="token builtin class-name">return</span> <span class="token number">1</span>
  <span class="token keyword">fi</span>
<span class="token punctuation">}</span>

<span class="token comment"># shuffle an array using the rand function</span>
<span class="token comment"># GLOBALS: _array, _RANDOM</span>
<span class="token function-name function">shuffle</span><span class="token punctuation">(</span><span class="token punctuation">)</span> <span class="token punctuation">{</span>
  <span class="token builtin class-name">local</span> i tmp size
  <span class="token assign-left variable">size</span><span class="token operator">=</span><span class="token variable">${<span class="token operator">#</span>_array<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
  <span class="token keyword">for</span> <span class="token variable"><span class="token punctuation">((</span>i<span class="token operator">=</span>size<span class="token operator">-</span><span class="token number">1</span><span class="token punctuation">;</span> i<span class="token operator">></span><span class="token number">0</span><span class="token punctuation">;</span> i<span class="token operator">--</span><span class="token punctuation">))</span></span><span class="token punctuation">;</span> <span class="token keyword">do</span>
    <span class="token keyword">if</span> <span class="token operator">!</span> rand <span class="token variable"><span class="token variable">$((</span>i<span class="token operator">+</span><span class="token number">1</span><span class="token variable">))</span></span><span class="token punctuation">;</span> <span class="token keyword">then</span> <span class="token builtin class-name">exit</span> <span class="token number">1</span><span class="token punctuation">;</span> <span class="token keyword">fi</span>
    <span class="token assign-left variable">tmp</span><span class="token operator">=</span><span class="token variable">${_array<span class="token punctuation">[</span>i<span class="token punctuation">]</span>}</span> _array<span class="token punctuation">[</span>i<span class="token punctuation">]</span><span class="token operator">=</span><span class="token variable">${_array<span class="token punctuation">[</span>$_RANDOM<span class="token punctuation">]</span>}</span> _array<span class="token punctuation">[</span><span class="token variable">$_RANDOM</span><span class="token punctuation">]</span><span class="token operator">=</span><span class="token variable">$tmp</span>
  <span class="token keyword">done</span>
<span class="token punctuation">}</span>

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token string">"1st item"</span> <span class="token string">"2nd item"</span> <span class="token string">"3rd item"</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>
1st item 2nd item 3rd item
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">_array</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token string">"<span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span><span class="token punctuation">)</span><span class="token punctuation">;</span> shuffle <span class="token punctuation">;</span> <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token string">"<span class="token variable">${_array<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>"</span><span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myArray<span class="token punctuation">[</span>@<span class="token punctuation">]</span>}</span>
2nd item 1st item 3rd item
</code></pre></div><h3 id="how-to-check-if-a-bash-array-contains-a-value">How to check if a Bash Array contains a value?</h3> <p>There is no <em>in array</em> operator in bash to check if an array contains a value. Instead, to check if a bash array contains a value you will need to test the values in the array by using a <a href="/bash/how-to-script-powerful-bash-if-statement/#what-are-the-bash-conditional-expressions">bash conditional expression</a> with the binary operator <code>=~</code>. The string to the right of the operator is considered a <code>POSIX</code> <a href="/bash/how-to-use-bash-wildcards-for-globbing/">extended regular expression</a> and matched accordingly. Be careful, this will not look for an exact match as it uses a shell regex.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span>a b c d<span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token string">'a'</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
<span class="token function">yes</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token string">'e'</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
no

<span class="token comment"># Return True even for partial match</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span>a1 b1 c1 d1 ee<span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token string">'a'</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
<span class="token function">yes</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token string">'a1'</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
<span class="token function">yes</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token string">'e'</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
<span class="token function">yes</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token string">'ee'</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
<span class="token function">yes</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
<span class="token number">456</span> <span class="token number">123</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token number">3</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
<span class="token function">yes</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token number">123</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
<span class="token function">yes</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token number">1234</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span>
no
</code></pre></div><p>In order to look for an exact match, your <code>regex</code> pattern needs to add extra space before and after the value like <code>(^|[[:space:]])"VALUE"($|[[:space:]])</code>.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token punctuation">(</span>^<span class="token operator">|</span><span class="token punctuation">[</span><span class="token punctuation">[</span>:space:<span class="token punctuation">]</span><span class="token punctuation">]</span><span class="token punctuation">)</span><span class="token string">"12"</span><span class="token punctuation">(</span>$<span class="token operator">|</span><span class="token punctuation">[</span><span class="token punctuation">[</span>:space:<span class="token punctuation">]</span><span class="token punctuation">]</span><span class="token punctuation">)</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span> 
no
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token punctuation">[</span><span class="token punctuation">[</span> <span class="token variable">${myAssociativeArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> <span class="token operator">=</span>~ <span class="token punctuation">(</span>^<span class="token operator">|</span><span class="token punctuation">[</span><span class="token punctuation">[</span>:space:<span class="token punctuation">]</span><span class="token punctuation">]</span><span class="token punctuation">)</span><span class="token string">"123"</span><span class="token punctuation">(</span>$<span class="token operator">|</span><span class="token punctuation">[</span><span class="token punctuation">[</span>:space:<span class="token punctuation">]</span><span class="token punctuation">]</span><span class="token punctuation">)</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> <span class="token string">'yes'</span> <span class="token operator">||</span> <span class="token builtin class-name">echo</span> <span class="token string">'no'</span> 
<span class="token function">yes</span>
</code></pre></div><p>With the Bash Associative Arrays, you can extend the solution to test values with <code>[[ -z "${myArray[$value]}" ]]</code>.</p> <div class="language-bash extra-class"><pre class="language-bash"><code><span class="token comment"># delete previously set declaration of myArray and</span>
<span class="token comment"># prevent the error `bash: myArray: cannot convert indexed to associative array`</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">unset</span> myArray 

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">declare</span> -A <span class="token assign-left variable">myArray</span><span class="token operator">=</span><span class="token punctuation">(</span><span class="token punctuation">[</span>one<span class="token punctuation">]</span><span class="token operator">=</span>un <span class="token punctuation">[</span>two<span class="token punctuation">]</span><span class="token operator">=</span>deux <span class="token punctuation">[</span>three<span class="token punctuation">]</span><span class="token operator">=</span>trois<span class="token punctuation">)</span>
<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token builtin class-name">echo</span> <span class="token variable">${myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span>
deux trois un

<span class="token punctuation">[</span>me@linux ~<span class="token punctuation">]</span>$ <span class="token keyword">for</span> <span class="token for-or-select variable">value</span> <span class="token keyword">in</span> one two three four
<span class="token operator">></span> <span class="token keyword">do</span>
<span class="token operator">></span>     <span class="token builtin class-name">echo</span> -n <span class="token string">"<span class="token variable">$value</span> is "</span>
<span class="token operator">></span>     <span class="token punctuation">[</span><span class="token punctuation">[</span> -z <span class="token string">"<span class="token variable">${myArray<span class="token punctuation">[</span>$value<span class="token punctuation">]</span>}</span>"</span> <span class="token punctuation">]</span><span class="token punctuation">]</span> <span class="token operator">&&</span> <span class="token builtin class-name">echo</span> -n <span class="token string">'*not* '</span>
<span class="token operator">></span>     <span class="token builtin class-name">echo</span> <span class="token string">"a member of ( <span class="token variable">${<span class="token operator">!</span>myArray<span class="token punctuation">[</span>*<span class="token punctuation">]</span>}</span> )"</span>
<span class="token operator">></span> <span class="token keyword">done</span>
one is a member of <span class="token punctuation">(</span> two three one <span class="token punctuation">)</span>
two is a member of <span class="token punctuation">(</span> two three one <span class="token punctuation">)</span>
three is a member of <span class="token punctuation">(</span> two three one <span class="token punctuation">)</span>
four is *not* a member of <span class="token punctuation">(</span> two three one <span class="token punctuation">)</span>
</code></pre></div></div></div></div></div></section></div></div></div></div></main> <div></div> <div><section id="latest-posts" style="padding:0 0" data-v-7090a28a><div class="container" data-v-7090a28a><div class="row mx-auto justify-center" data-v-7090a28a><div class="text-center col col-12" data-v-7090a28a><div class="container pl-1 align width" data-v-7090a28a><span class="primary--text my-1 title"> Related <span class="amber--text text--darken-1 font-italic text-capitalize" data-v-7090a28a>linux</span> posts that you may like... </span> <div class="container"><div class="row pt-0"><div class="px-auto mx-auto col-sm-6 col-lg-3 col-12"><div class="mx-auto my-1 pb-8 fill-height v-card v-sheet theme--light" style="max-width:450px"><a href="/bash/how-to-create-simple-menu-with-the-shell-select-loop/" class="white--text nodeco caption"><div class="d-flex flex-nowrap pa-0 ma-0" style="height:3.3em"><div class="d-flex secondary align-center px-2 ma-0 b-tl-r5"><span aria-hidden="true" class="v-icon notranslate v-icon--svg theme--light white--text"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M21,6V8H3V6H21M3,18H12V16H3V18M3,13H21V11H3V13Z"></path></svg></span></div><div class="d-flex pl-2 flex-grow-1 primary align-center text-left b-tr-r5 font-weight-regular subtitle-2" style="line-height:100%">How To Create Simple Menu with the Shell Select Loop?</div></div> <div flat="" tile="" src="/assets/tn/450x300/how-to-create-simple-menu-with-the-shell-select-loop.jpg" srcset="/assets/tn/150x100/how-to-create-simple-menu-with-the-shell-select-loop.jpg 150w,/assets/tn/450x300/how-to-create-simple-menu-with-the-shell-select-loop.jpg 450w" aspect-ratio="1.7777777777777777" class="v-image v-responsive theme--light"><div class="v-responsive__sizer" style="padding-bottom:56.25%"></div><div class="v-image__image v-image__image--preload v-image__image--cover" style="background-position:center center"></div><div class="v-responsive__content"></div></div></a> <div class="v-card__text text-justify pa-2 grey--text text--darken-3 body-2">The select loop is not a regular shell loop. It can be used in Bash to generate a simple menu from which a user can select numbered options.</div> <div class="v-card__actions" style="position:absolute;bottom:0;width:100%"><div class="spacer"></div> <a href="/bash/how-to-create-simple-menu-with-the-shell-select-loop/" class="ma-0 v-btn v-btn--flat v-btn--router v-btn--text theme--light v-size--default primary--text"><span class="v-btn__content"><span aria-hidden="true" class="v-icon notranslate mt-0 v-icon--left v-icon--svg theme--light" style="font-size:16px;height:16px;width:16px"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="16px" width="16px" role="img" aria-hidden="true"><path d="M22,3H5A2,2 0 0,0 3,5V9H5V5H22V19H5V15H3V19A2,2 0 0,0 5,21H22A2,2 0 0,0 24,19V5A2,2 0 0,0 22,3M7,15V13H0V11H7V9L11,12L7,15M20,13H13V11H20V13M20,9H13V7H20V9M17,17H13V15H17V17Z"></path></svg></span> READ </span></a></div></div></div><div class="px-auto mx-auto col-sm-6 col-lg-3 col-12"><div class="mx-auto my-1 pb-8 fill-height v-card v-sheet theme--light" style="max-width:450px"><a href="/bash/what-is-the-right-way-to-loop-in-bash/" class="white--text nodeco caption"><div class="d-flex flex-nowrap pa-0 ma-0" style="height:3.3em"><div class="d-flex secondary align-center px-2 ma-0 b-tl-r5"><span aria-hidden="true" class="v-icon notranslate v-icon--svg theme--light white--text"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M21,6V8H3V6H21M3,18H12V16H3V18M3,13H21V11H3V13Z"></path></svg></span></div><div class="d-flex pl-2 flex-grow-1 primary align-center text-left b-tr-r5 font-weight-regular subtitle-2" style="line-height:100%">What is the Right Way to Loop in Bash?</div></div> <div flat="" tile="" src="/assets/tn/450x300/what-is-the-right-way-to-loop-in-bash.jpg" srcset="/assets/tn/150x100/what-is-the-right-way-to-loop-in-bash.jpg 150w,/assets/tn/450x300/what-is-the-right-way-to-loop-in-bash.jpg 450w" aspect-ratio="1.7777777777777777" class="v-image v-responsive theme--light"><div class="v-responsive__sizer" style="padding-bottom:56.25%"></div><div class="v-image__image v-image__image--preload v-image__image--cover" style="background-position:center center"></div><div class="v-responsive__content"></div></div></a> <div class="v-card__text text-justify pa-2 grey--text text--darken-3 body-2">Looping over a list of numbers or words is a building block in shell scripts. Learn how to write Bash loops, including for loop, while loop, and until loop.</div> <div class="v-card__actions" style="position:absolute;bottom:0;width:100%"><div class="spacer"></div> <a href="/bash/what-is-the-right-way-to-loop-in-bash/" class="ma-0 v-btn v-btn--flat v-btn--router v-btn--text theme--light v-size--default primary--text"><span class="v-btn__content"><span aria-hidden="true" class="v-icon notranslate mt-0 v-icon--left v-icon--svg theme--light" style="font-size:16px;height:16px;width:16px"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="16px" width="16px" role="img" aria-hidden="true"><path d="M22,3H5A2,2 0 0,0 3,5V9H5V5H22V19H5V15H3V19A2,2 0 0,0 5,21H22A2,2 0 0,0 24,19V5A2,2 0 0,0 22,3M7,15V13H0V11H7V9L11,12L7,15M20,13H13V11H20V13M20,9H13V7H20V9M17,17H13V15H17V17Z"></path></svg></span> READ </span></a></div></div></div><div class="px-auto mx-auto col-sm-6 col-lg-3 col-12"><div class="mx-auto my-1 pb-8 fill-height v-card v-sheet theme--light" style="max-width:450px"><a href="/linux/what-is-the-best-way-to-count-files-in-a-directory/" class="white--text nodeco caption"><div class="d-flex flex-nowrap pa-0 ma-0" style="height:3.3em"><div class="d-flex secondary align-center px-2 ma-0 b-tl-r5"><span aria-hidden="true" class="v-icon notranslate v-icon--svg theme--light white--text"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M21,6V8H3V6H21M3,18H12V16H3V18M3,13H21V11H3V13Z"></path></svg></span></div><div class="d-flex pl-2 flex-grow-1 primary align-center text-left b-tr-r5 font-weight-regular subtitle-2" style="line-height:100%">What is the Best Way to Count Files in a Directory?</div></div> <div flat="" tile="" src="/assets/tn/450x300/what-is-the-best-way-to-count-files-in-a-directory.jpg" srcset="/assets/tn/150x100/what-is-the-best-way-to-count-files-in-a-directory.jpg 150w,/assets/tn/450x300/what-is-the-best-way-to-count-files-in-a-directory.jpg 450w" aspect-ratio="1.7777777777777777" class="v-image v-responsive theme--light"><div class="v-responsive__sizer" style="padding-bottom:56.25%"></div><div class="v-image__image v-image__image--preload v-image__image--cover" style="background-position:center center"></div><div class="v-responsive__content"></div></div></a> <div class="v-card__text text-justify pa-2 grey--text text--darken-3 body-2">Learn how to count the number of files in a directory using the Linux command line ls, find, and a native bash shell solution with globs and arrays.</div> <div class="v-card__actions" style="position:absolute;bottom:0;width:100%"><div class="spacer"></div> <a href="/linux/what-is-the-best-way-to-count-files-in-a-directory/" class="ma-0 v-btn v-btn--flat v-btn--router v-btn--text theme--light v-size--default primary--text"><span class="v-btn__content"><span aria-hidden="true" class="v-icon notranslate mt-0 v-icon--left v-icon--svg theme--light" style="font-size:16px;height:16px;width:16px"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="16px" width="16px" role="img" aria-hidden="true"><path d="M22,3H5A2,2 0 0,0 3,5V9H5V5H22V19H5V15H3V19A2,2 0 0,0 5,21H22A2,2 0 0,0 24,19V5A2,2 0 0,0 22,3M7,15V13H0V11H7V9L11,12L7,15M20,13H13V11H20V13M20,9H13V7H20V9M17,17H13V15H17V17Z"></path></svg></span> READ </span></a></div></div></div><div class="px-auto mx-auto col-sm-6 col-lg-3 col-12"><div class="mx-auto my-1 pb-8 fill-height v-card v-sheet theme--light" style="max-width:450px"><a href="/bash/five-mistakes-to-avoid-for-writing-high-quality-bash-comments/" class="white--text nodeco caption"><div class="d-flex flex-nowrap pa-0 ma-0" style="height:3.3em"><div class="d-flex secondary align-center px-2 ma-0 b-tl-r5"><span aria-hidden="true" class="v-icon notranslate v-icon--svg theme--light white--text"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="24" width="24" role="img" aria-hidden="true"><path d="M21,6V8H3V6H21M3,18H12V16H3V18M3,13H21V11H3V13Z"></path></svg></span></div><div class="d-flex pl-2 flex-grow-1 primary align-center text-left b-tr-r5 font-weight-regular subtitle-2" style="line-height:100%">5 Mistakes To Avoid For Writing High-Quality Bash Comments</div></div> <div flat="" tile="" src="/assets/tn/450x300/5-mistakes-to-avoid-for-writing-high-quality-bash-comments.jpg" srcset="/assets/tn/150x100/5-mistakes-to-avoid-for-writing-high-quality-bash-comments.jpg 150w,/assets/tn/450x300/5-mistakes-to-avoid-for-writing-high-quality-bash-comments.jpg 450w" aspect-ratio="1.7777777777777777" class="v-image v-responsive theme--light"><div class="v-responsive__sizer" style="padding-bottom:56.25%"></div><div class="v-image__image v-image__image--preload v-image__image--cover" style="background-position:center center"></div><div class="v-responsive__content"></div></div></a> <div class="v-card__text text-justify pa-2 grey--text text--darken-3 body-2">Adding comments in your Bash scripts is necessary to ensure maintainability over time. This post covers 5 Bash comments mistakes to avoid in your shell scripts.</div> <div class="v-card__actions" style="position:absolute;bottom:0;width:100%"><div class="spacer"></div> <a href="/bash/five-mistakes-to-avoid-for-writing-high-quality-bash-comments/" class="ma-0 v-btn v-btn--flat v-btn--router v-btn--text theme--light v-size--default primary--text"><span class="v-btn__content"><span aria-hidden="true" class="v-icon notranslate mt-0 v-icon--left v-icon--svg theme--light" style="font-size:16px;height:16px;width:16px"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="16px" width="16px" role="img" aria-hidden="true"><path d="M22,3H5A2,2 0 0,0 3,5V9H5V5H22V19H5V15H3V19A2,2 0 0,0 5,21H22A2,2 0 0,0 24,19V5A2,2 0 0,0 22,3M7,15V13H0V11H7V9L11,12L7,15M20,13H13V11H20V13M20,9H13V7H20V9M17,17H13V15H17V17Z"></path></svg></span> READ </span></a></div></div></div> <div align="center" justify="center" class="col col-12"><a href="/linux/1/" class="ma-2 v-btn v-btn--depressed v-btn--flat v-btn--outlined v-btn--router v-btn--text theme--light v-size--default primary--text"><span class="v-btn__content"><span aria-hidden="true" class="v-icon notranslate mt-0 v-icon--left v-icon--svg theme--light" style="font-size:16px;height:16px;width:16px"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" height="16px" width="16px" role="img" aria-hidden="true"><path d="M22,3H5A2,2 0 0,0 3,5V9H5V5H22V19H5V15H3V19A2,2 0 0,0 5,21H22A2,2 0 0,0 24,19V5A2,2 0 0,0 22,3M7,15V13H0V11H7V9L11,12L7,15M20,13H13V11H20V13M20,9H13V7H20V9M17,17H13V15H17V17Z"></path></svg></span> MORE POSTS </span></a></div></div></div></div></div></div></div></section></div> <footer class="v-footer font-weight-medium overline text-center white--text v-sheet theme--dark primary" data-v-a515c158> © 2019 <a href="https://nicolas.brousse.info" class="white--text" data-v-a515c158>Nicolas Brousse</a>. <div class="spacer" data-v-a515c158></div></footer></div></div><div class="global-ui"></div></div> <script src="/assets/js/app.f2436115.js" defer></script><script src="/assets/js/44.8c8e5ed0.js" defer></script><script src="/assets/js/18.a6aa1d28.js" defer></script><script src="/assets/js/52.45429b0b.js" defer></script><script src="/assets/js/46.9b4ac1d9.js" defer></script><script src="/assets/js/2.e285a825.js" defer></script><script src="/assets/js/1.a1680d06.js" defer></script><script src="/assets/js/62.2b7abdca.js" defer></script><script src="/assets/js/23.617fc7ac.js" defer></script><script src="/assets/js/41.fe8e8243.js" defer></script><script src="/assets/js/37.1f6a2ba5.js" defer></script><script src="/assets/js/47.ae9309c7.js" defer></script> </body> </html> 